読者です 読者をやめる 読者になる 読者になる

Happy My Life

日常とか技術とか

CarbonEmacs2008秋版のrailsでエラーが

Error

CarbonEmacs 2008秋版が出ていたので2008夏版と入れかえたのだが、error: this is broken, use find-files-in-project.el insteadと起動時にエラーが表示されるようになってしまった。 どこでエラーが表示されているか確認するために、

/Applications/Emacs.app/Contents/MacOS/Emacs –init-debug

でエラーの場所を確認してみたところ、どうも(require ‘rails)でエラーになっているようだ。

rails.elを動作させる時に必須だと思われるfind-recursive.elsnippet.elが、Emacs.appのsite-lispに無かったので、ロードパス(~/.emacs.d/)の通ったところに置いたところ、rails-modeも動くようになった。 夏版の時に自分でfind-recursive.elとsnippet.elはEmacs.app以下にインストールしていたのかな。うーむ。