読者です 読者をやめる 読者になる 読者になる

Happy My Life

日常とか技術とか

DapperにRuby 1.8.6をインストールする

mongrel_culsterを動かすと、

Ruby version is not up-to-date; loading cgi_multipart_eof_fix

なんてメッセージが表示されるのだが、これはRubyのバージョンが1.8.6以前だった場合に出るメッセージなんだそうだ。

Ubuntu Dapperのrubyの最新バージョンは1.8.4なので当然メッセージが表示される。放っておいても問題は無いのだけど、気持ち悪いので最新版(3/18現在 1.8.6-p114)にバージョンアップすることにした。 手順は以下の通り。

$sudo apt-get install build-essential
$sudo apt-get install libreadline5 libreadline5-dev
$ wget ftp://ftp.ruby-lang.org/pub/ruby/1.8/ruby-1.8.6-p114.tar.bz2
$ tar xvjf ruby-1.8.6-p114.tar.bz2
$ cd ruby-1.8.6-p114
$ apt-get build-dep ruby1.8
$ ./configure --prefix=/usr/local --enable-pthread --with-readline-dir=/usr/local
$ make
$ sudo make install
$ ruby -v
ruby 1.8.6 (2008-03-03 patchlevel 114) [x86_64-linux]

と、最新版になりましたとさ。